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COMMUNICATION SKILL 

 
What is communication? 
The imparting or exchanging of information by speaking, writing or using some other medium 
and means of sending or receiving information. 
 
What is Writing? 
Writing is a form of communication that allows students to put their feelings and ideas on 
paper, to organize their knowledge and beliefs into convincing arguments, and to convey 
meaning through well-constructed text. In its most advanced form, written expression can be 
as vivid as a work of art. 
 
What are Phrases? 
 Phrases are a group of words that work together to communicate an element of speech. 
Differet types of phrases are: 

1. Prepositional  
2. Appositive  
3. Participial 
4. Gerund 
5. Infinitive 

 
What is a sentence? 
A set of words that is complete in itself, typically containing a subject and predicate, conveying 
a statement, question, exclamation, or command, and consisting of a main clause and 
sometimes one or more subordinate clauses. 

 
What is a paragraph? 



 

A paragraph is a series of sentences that are organized and coherent, and are all related to a 
single topic. 
 
What are the different barriers to effective communication? 
 
Physical Barriers – Physical barriers separate people from each other and mark territories. 
These barriers can often be seen in the workplace where offices and closed doors stop 
communication. 
Language Barriers – Not using words another can understand will certainly stop your 
message from being conveyed. This not only applies to actual languages but also 
expressions, format used, buzz words and other jargon. 
Gender Barriers – Variation exists among masculine and feminine styles of communication. 
There are distinct differences between the speech patterns in a man and those in a woman. 
Attitudinal Barriers - as those behaviors or perceptions that are divisive in nature – the ones 
that can lead to nagging doubt, sullen disagreement or even overt conflict. 
Perceptual Barriers – Different world views can create misunderstanding. People tend to 
interpret messages from their own point of view or ideologies. Without thinking, one might 
only view a message from his or her own mindset rather than looking at it from another 
viewpoint. 
Cultural Barriers – Ethnic, religious, and social differences can often create 
misunderstandings when trying to communicate. These differences can also affect one’s 
perception and create confusion in getting a message. 
Emotional Barriers –If one is consumed with emotion he will have difficulty in 
understanding what is communicated. Hostility, anger, fear, and other emotions make it 
hard to hear outside one’s own self. 
 
What are the different technique to handle the barriers to effective communication? 
 
Engage in face-to-face interactions whenever possible. As you've probably learned from 
experience, text messages and even emails can be misinterpreted without the nonverbal 
“assist” of facial expressions, tone and inflection 
Reduce or eliminate distractions around you. Noise from other people and office machines 
can sink even the most pleasant interactions, dooming them to a rough start. 
Try to assess the needs of the receiver. This is not an easy objective. But as an employer, 
look at the bright side: you're privy to some attitudinal variables: age, culture, education, 
experience, gender and race. 
Hone your active listening skills.  
a) Acknowledge the other person's ideas, thoughts or feelings. Paraphrase the other 
person's words to ensure understanding. 
b) Ask questions without judging. Summarize and clarify what you hear. Offer your opinion if 
it's requested. 



 

c) Organize your thoughts. You don't have to write notes, but if doing so helps you organize 
what you want to say and how you want to say it, then by all means, start writing. 
Soften your tone and language. As the boss, you know people watch your every move, so 
you also know that being courteous and professional is a must in every interaction. To 
defeat any attitudinal barriers, it can help immensely to maintain a gentle, reassuring tone 
and use simple, non-confrontational language. Keeping sentences short and direct can also 
help to prevent any misunderstandings. 
Encourage feedback. Even this seemingly benign step can be fraught with peril, if “the other 
guy” clams up and disses you behind your back. Now might be a good time to remember the 
advice about how the receiver also bears responsibility for whether a two-way exchange is a 
success or a failure. 
 

ICT(INFORMATION AND COMMUNICATION TECHNOLOGY) 

Basic Computer Operations 
 
What do you mean by Operating System and its functions? 
An operating system is the basic software that controls the computer. It serves as an 
interface between the user and the computer. 
Some of the functions of Operating system are: 

 It manages all the devices of a computer and keeps track of the status of the device, 
whether it is busy or not. 

 It also checks whether the device is functioning properly or not. 

 It also controls software resources of the computer. 

 it manages the computer memory and keeps track of which memory space 

 is in use by which program and which space is free. 

 It manages the structure of the files and directories on a computer system. 

 It keeps track of the amount of disk space used by a specific file. 

 It allows you to create, copy, move and delete files. 
 

What are the different types of Operating Systems? Explain 

 DOS DOS (Disk Operating System) 

 Windows It is an operating system developed by Microsoft. 

 Linux It is an operating system designed for personal computers. It is a free and open-
source software 

 Mobile operating Systems 

 Android 

 Symbian 

  Windows Phone 

  iOS 
 

Types of Operating Systems  



 

 
The different types of operating systems are as follows: 
Interactive (GUI-based) A graphical user interface is a user-friendly operating system in which 
commands can be entered by clicking/double-clicking/right clicking a mouse. Windows 
operating system is an example of an interactive operating system. 
Single-user , single-task operating system This type of operating system allows only one user 
to do a task on the computer and one thing at a time. 
Single-user, multi-task operating system This type of operating system is used on Desktop 
computers, laptops, where a single user can operate on several programs at the same time. 
For example, Windows, Apple MacOS are examples of single-user multitask operating system. 
Multi-user A multi-user operating system enables multiple users to work on the same 
computer at different times or simultaneously. 
Real Time A real time operating system is used to control machinery, scientific instruments, 
like robots, in complex animations and computer controlled automated machines.  
A real-time operating system is a computing environment that reacts to input within a specific 
period of time. It manages the resources of the computer so that any particular operation is 
executed in the same amount of time every time it is executed. 
Windows CE and Lynx OS are examples of real-time operating systems. 
Distributed A distributed operating system runs on a set of computers that are interconnected 
by a network. It combines the different computers in the network into a single integrated 
computer and storage location. Windows, UNIX, and LINUX are examples of distributed 
operating systems. 
 

Windows 7 operating system 
 
What is windows 7 Operating System? 
Windows 7 is an operating system developed by Microsoft and is used on personal 
computers. 
 
Describe the File System used by operating system. 
Everything we store on your computer is stored in the form of a file. File system is a way in 
which you give name to a file, store it and retrieve it. There are specific naming conventions 
for naming files or folders, like characters that can be used, maximum number of characters, 
etc. 
Files can be separately placed into groups, called folders/directories. Each directory/folder can 
contain related files and/or sub-folders. A sub-folder may contain one or more files and sub-
folders within. This allows easy accessibility of files. 
Files are managed in a hierarchy. This allows you to view the files in the current directory and 
then move to sub-directories. 
 



 

 
File Structure 1 

Importance and need of care and maintenance of computer 
 
What is the Importance and need of care and maintenance of computer? 
Computer systems require maintenance so that the system works efficiently. Poor 
maintenance may lead to system failure. 
Computer virus, malware, and other harmful softwares can cause damage to the working of 
the computer. If anti-virus is installed in the computer, and is updated and run periodically, 
then any loss of data can be prevented. 
Regular maintenance of the system includes installing updates, security, taking backups, 
scans, etc 
 
Both internal and external parts of the computer system should be taken care of. 
1. Keep the computer dust free. 
2. Do not eat or drink while working on the computer. Food or drink may spill on the system. 
3. To keep the keyboard clean, make sure your hands are clean before using it. 
4. CDs and DVDs should be handled carefully so that it does not get any scratches. 
5. Keep keyboard covered when not in use. 
 
Preparing computer against virus 
To prevent our computer from being infected with virus, we should install anti-virus 
software, run it periodically and keep it updated so that it can scan and remove new 
viruses. 
Antivirus software is a program designed to detect and remove malicious programs from 
the computer. 
Some examples of antivirus software are McAfee VirusScan, Norton AntiVirus, Microsoft 
Security essentials, and Quick Heal. 
 

 



 

SELF-MANAGEMENT SKILLS 

 
Meaning and Importance of Stress Management 
Stress Management refers to focusing human efforts for maintaining a healthy body and mind 
capable of better withstanding stressful situations. 
A Stress well managed can help one view events and situations as challenges and contributes 
in the growth of individual. Unmanaged stress leads to anxiety and sorrow resulting in ill status 
of mental and physical health. Stress causal agents can have following origins. 

 
Types of Stress 1 

 

 
 
 
What are the different types of Stresses? Explain 
 
Mental: Students can be left overwhelmed, if they are unable to handle their assignment 
submission deadlines and examinations grades. Overly high expectations from self can leave 
one with chronic anxiety and stress. 
Physical: As children grow up they may seek more independence, may become critically 
conscious of their looks and have to cope up with hormonal changes. Issues related to general 
well-being and health of an individual can lead to low self-esteem and cause stress. 
Social : Discord amongst family members, peer pressure for doing things which kids will 
generally avoid , maintaining balance in relationships amongst friends, status show off may 
lead to stress at times. 
Financial: Youngsters may have aspirational financial stress. This may of becoming 
Independent or Finances aspirational stress may 

What are the different Stress Management Techniques? Explain 

Physical Exercise 
When stress affects the brain, rest of the body also feels the impact. Physical exercise in 
the form of walking, skipping or for that matter indulging in any sports has been found 



 

to relieve stress as they stabilize mood, improve self-esteem and induce sleep. 
Yoga 
Yoga is a school of Hindu philosophy reduces stress, which includes a series of postures 
and breathing exercises practiced to achieve control of body and mind. 
Meditation 
It is a practice where an individual is supposed to focus his/her mind on a particular 
object, thought or activity to achieve a calm mental state reducing stress. 
Enjoying 
Recreational activities like watching movies, attending concerts, playing games, involving in 
adventure sports, singing, dancing or even sketching can help individuals transcend to a 
happier mental state and help manage stress. 
Going On Vacations with Family and Friends 
Vacations provide an opportunity of taking a holiday from our routine and appreciate 
different facets of life. Vacations can be taken up to friends and relatives place as well as 
to far flung attractive locations. Vacationing helps in de-stressing individuals. 
Taking Nature Walks 
Taking nature walks in a pristine environment of a national park or a sanctuary or a trail 
in country side / village, brings us a calmness by allowing our over stimulated minds a 
chance to relax and helps us relax. 

ENTREPRENEURIAL SKILLS 

What is Entrepreneurship? 

What is Entrepreneur? 

Describe Entrepreneurship Development? 

Entrepreneurship development is the process of strengthening the skills and knowledge of 
budding and existing entrepreneurs by handholding them during their entrepreneurial 
journey. It involves enabling entrepreneurs through structured training and institution building 
programs, which empowers them to run their business effectively and efficiently. 
 
What are the different Objectives of Entrepreneurship Development? 

 Assisting entrepreneurs in undergoing the process of entrepreneurship. 

 Helping aspiring entrepreneurs start and grow dynamic businesses that provide high 
value add. 

 Developing the motivational needs of entrepreneurs. 

 Training entrepreneurs to develop the required skills and gain knowledge for running 
and managing a   new business. 

 Supporting entrepreneur in creating effective business plans. 

 Providing incubation and acceleration to new ideas. 
 



 

What are the different phases of Entrepreneurship Development? 
Stimulatory phase : 
It is called stimulatory phase because it includes activities which stimulate the individual’s 
need, interest and motivation for being an entrepreneur. 
Support phase 
This phase is all about supporting the new ventures in their establishment by mentoring, 
incubating, financing and advising the entrepreneurs. This includes providing support across 
various activities such as registration of enterprises; designing the right business model; 
development of the product prototype etc.  
Sustenance phase: 
In this phase, entrepreneurship development is focused on helping enterprises to grow after 
they have been established. It helps in continuous and efficient functioning of enterprises 
within a society. 
 

National Skill Development Mission: 

Make in India 
It is an initiative of the Government of India, launched on 25th September 2014 to encourage 
multi-national, as well as domestic, companies to manufacture their products in India. The 
major objective behind the initiative is to focus on job creation and skill enhancement in 25 
sectors of the economy. Make in India also aims at high quality standards and minimising the 
impact on the environment. The initiative hopes to attract capital and technological 
investment in India. 
Start-Up India 
The main aim of Start-up India is to encourage entrepreneurship among the youth of India. 
The ‘Start-up India: Stand up India’ promotes bank financing for start-ups and offer incentives 
to enhance entrepreneurship and job creation. This initiative aims to provide a new dimension 
to entrepreneurship and help in setting up of a network of start-ups in the country. 
 ATAL Innovation Mission (AIM) 
It also called as AIM Platform and was established through 2015 budget within National 
Institution for Transforming India (NITI) to provide innovation promotion platform involving 
academicians, and drawing upon national and international experiences to foster a culture of 
innovation, research and development. 
 
What are the different functions of an entrepreneur? 

1. Entrepreneurial functions 
a. Organisation Building and Management 
b. Risk taking 
c. Risk taking 

 
2. Promotional functions 

a. Idea Discovery 



 

b. Detailed Investigation 
c. Assembling the Requirements 
d. Financing: 

 
3. Managerial functions 

a. Planning 
b. Organizing 
c. Directing 
d. Staffing 

 
Define Importance of Entrepreneurs. 
 

1. Free market evolution 
2. Efficiency improvements 
3. New markets 
4. New values 

 
What are the myths of Entrepreneurship? 
Entrepreneurs are born that way 
Many people assume that entrepreneurial qualities are innate and that only people who have 
certain natural talents can be entrepreneurs. However, the truth is that almost anyone can 
become an entrepreneur if they can learn the necessary skills. Entrepreneurs may be  
gregarious extroverts or quiet introverts; they may be “big picture” thinkers or more focused 
on the details of executing an idea. Entrepreneurship is a learned skill, not a natural-born 
ability. 
 All entrepreneurs have great ideas 
Some people may not attempt to start their own business because they don’t have a unique 
idea. It is not needed to reinvent the wheel to be an entrepreneur. There is nothing wrong 
with taking an existing idea and making your own business out of it. 
The only requirement is a good idea 
Even the very best ideas, ones with the potential to disrupt an entire industry, need proper 
execution to become reality. Ideas are important, but so are planning, talent, leadership, 
communication, and a host of other factors. 
Businesses either flourish or fail 
Because the select few start-ups that skyrocket out of the gate receive the bulk of the media, 
it’s easy to adopt an all-or-nothing outlook on entrepreneurship. While many ventures make it 
big and many fail, a lot of businesses are run with patience and strategy with a focus on self-
sustenance and gradual growth. 
Entrepreneurs take lots of risks 
Entrepreneurs take risks. With that said, they don’t necessarily take lots of risks or put 
themselves in high-risk situations all the time. Entrepreneurs learn how to take calculated 
risks. It is all about balancing the risk and reward. 



 

One must know everything before starting a business 
Real entrepreneurs thrive on being in a constant state of learning. They enjoy creating, 
improvising and pushing boundaries. Being new and even somewhat naïve can be an asset in 
today’s rapidly changing world. That’s because succeeding at entrepreneurship requires 
energy, innovation and the ability to push yourself outside your comfort zone. It’s often not 
what you know, but how fast you learn, that counts. 
A lot of money is required to start any business 
While certain amount of capital is required for take a business off the ground, it varies 
depending on the business. The key in entrepreneurship is to start with resources available 
and grow slowly and steadily. It is not necessary that one should fear or deter from 
entrepreneurship due to lack of financial resources. 
 
What are the advantages and disadvantages of entrepreneurship? 
 
Advantages 
Control. One can choose the work they like to do, use their strengths and skills, and follow 
their own style of working and doing things. This can result in more work satisfaction. 
Excitement. Entrepreneurship can be exciting and many entrepreneurs consider their work 
highly enjoyable. Each day is filled with new opportunities to challenge one’s abilities, skills, 
and determination. 
Flexibility. Entrepreneurs can schedule their work hours around other commitments, 
including spending quality time with their families. 
Freedom. Freedom to work whenever they want, wherever they want, and however they 
want draws many people to entrepreneurship. Most entrepreneurs don’t consider their work 
actual work because they are doing something they love. 
Rational salary. As an entrepreneur, one’s income is directly related to their efforts and the 
success of the business. 
Disadvantages 
 
Administration. While making all the decisions can be a benefit, it can also be a burden. 
Being an entrepreneur comes with a lot of paperwork that can take up time and energy. 
Competition. Staying competitive is critical as a small business owner. One needs to 
differentiate their business from others in order to build a solid customer base and be 
profitable. 
Loneliness. It can be lonely and scary to be completely responsible for the success or failure 
of one’s business. 
No regular salary. Being an entrepreneur often means giving up the security of a regular 
paycheck. If business slows down, one’s personal income can be at risk. 
Work schedule. The work schedule of an entrepreneur can be unpredictable. A major 
disadvantage to being an entrepreneur is that it requires more work and longer hours than 
being an employee. 
 



 

GREEN SKILL 

 
What are the main sectors of the green economy? Explain. 

 E-waste management 

 Green transportation 

 Renewal energy 

 Green construction 

 Water management 
 
E-waste Management: 
E waste comprises of discarded electronic devices. Which can be reused, resale, 
salvaged, or recycled or disposed 
Green Transport: 
Green transport refers to making efficient and effective use of resources,modification of 
transport structure and making healthier travel choices. Green transport factors in climatic 
and environmental impact globally. Green transport is also termed as Smart transportation 
that supports and enhances walkable urbanization. It reduces congestion, reduces our 
dependency on cars and foreign oil, green transport is safer and less costly and helps save our 
planet. smart cycle 
Renewable energy: 
Energy that is collected from renewable resources, which are naturally replenished on a 
human timescale, sunlight, wind tide, rain waves, geo thermal heat. 
Green construction: 
Green construction is also referred as sustainable building; includes both the structure and 
processes that are environmental friendly, responsible and resource efficient through the 
building lifecycle i.e. from design, operation, maintenance renovation and demolition. 
 
Water Management: 
Water management is also referred as optimization of water usage. It’s management of water 
resources under a set of policies and regulation. Water once an abundant natural resource is 
becoming a valuable resource, due to draughts and over use. 
 
What are the objectives of the green economy? 
Green economy’s objective is to reduce environmental risks and ecological scarcities that aim 
for sustainable development, without degrading the environment. 
 
What is the role of government in greening economy? 
Government has important role for setting policies that serve, advance and protect the 
public’s interest in transitioning towards an energy system that is more sustainable from both 
a supply and environmental standpoint. Government can play crucial role in helping to plug 
gaps by conducting research. 



 

SUBJECT SKILLS 

 

Unit 2:- Web Applications 

Session 1:- WORKING WITH ACCESSIBILITY OPTIONS 

Q1:- What do you mean by Computer Accessibility? 

Ans:- Computer Accessibility refers to the user friendliness of a computer system for all, regardless of 
their disability. 

Q2:- What do you mean by Assistive Technology? 

Ans:- when a combination of hardware and software, it enables a person with a disability or impairment to 
use a computer. 
 

Q3:- What are the numerous types of impairment that impact computer usage? 

Ans:-  

 Cognitive impairments and learning disabilities, such as dyslexia, attention deficit-hyperactivity 
disorder (ADHD) or autism. 

 Visual impairment such as low-vision, complete or partial blindness, and color blindness. 

 Hearing impairment including deafness. 

 Motor or dexterity impairment such as paralysis, cerebral palsy, or carpal tunnel syndrome 
and repetitive strain injury. 

 

Q4:- Define the following terms:- 

a. Sticky Keys 

 Sticky Keys is an accessibility feature to help computer users with physical disabilities, but 

 it is also used by others as a means to reduce repetitive strain.  

 Sticky Keys allows the user to press and release a modifier key, such as Shift, Ctrl, Alt, or the 
Windows key, and have it remain active until any other key is pressed. 

b. Filter Keys 

 Filter Keys is a feature of Microsoft Windows. It is an accessibility function that tells the 
keyboard to ignore brief or repeated keystrokes, making typing easier for people with hand 
tremors. 
 

c. Toggle Keys 

 ToggleKeys is also a feature of Microsoft Windows. It is an accessibility function which is 
designed for people who have vision impairment or cognitive disabilities. 

 When ToggleKeys is turned on, computer emits sound cues when the locking keys (Caps 
Lock, Num Lock, or Scroll Lock) are pressed. 

d. Serial Keys 



 

 Serial Keys is an accessibility feature that assists people that have difficulty using a keyboard 
or a mouse (or both).  

 They can use special devices such as Sip, Puff and Breath Switches to provide input to the 
computer through Serial Ports. 

e. Sound Sentry 

 Sound Sentry is designed to help users with auditory impairments.  

 Sound Sentry generates visual warnings, such as a blinking title bar or a flashing border, 
whenever the computer generates a sound. 

 
f. High Contrast 

 High Contrast is an accessibility feature to assist people with vision impairment.  

 We can change the size and color of fonts and the background for ease of viewing. 
 

g. Cursor Options 
 Cursor Options is also an accessibility feature that assists people with vision impairment by 

changing the blink rate and width of the cursor 
 

h. Mouse Keys 
 Mouse Keys is an accessibility feature that assists people who have difficulty using a mouse.  

 This option uses the keyboard (especially numeric keypad) as a pointing device instead of a 
mouse. 
 

Session 2:- NETWORKING FUNDAMENTALS 

Q1:- What do you mean by computer network? 

Ans:- A computer network is a collection of computers and other hardware components interconnected 
           by communication channels (cables or satellites) that allow sharing of resources and information. 

Q2- Define the following Network Architectures? 

a. Peer-to-peer (P2P) Architecture: 

 Networks in which all computers have an equal status are called peer to peer networks. 

 Generally in such a network each terminal has an equally competent CPU. 
 

b. Client-Server Architecture: 

 Networks in which certain computers have special dedicated tasks, providing services to other 
computers (in the network) are called client server networks. 

 The computer(s) which provide services are called servers and the ones that use these services 
are called clients. 

 
Q3- Discuss the types of computer network? 
Ans:- There are three types of networks 

1. Local Area Network(LAN) 

 A local area network (LAN) is one which connects computers and devices in a limited 
geographical area such as home, school, computer laboratory, office building, or closely 
positioned group of buildings. 

 Usually local area networks offer very high speeds and are used for connecting computers and 
peripherals such as printers, scanners, etc. 

 



 

2. Metropolitan Area network (MAN) 

 A metropolitan area network (MAN) is a computer network that interconnects users with 
computer resources in a geographic region of the size of a metropolitan area. 

 The term MAN is applied to the interconnection of local area networks (LANs) in a city into a 
single larger network 

3. Wide Area Network(WAN) 

 A wide area network (WAN) is one which covers a broad area (i.e., any network that links across 
metropolitan, regional, or national boundaries).  

 The Internet is the most popular WAN, and is used by businesses, governments, non-profit 
organizations, individual consumers, artists, entertainers, and many others. 

 
Q4- Define Internet? 

Ans:- The Internet is a global system of interconnected computer networks that use the standard Internet 
protocol suite to serve billions of users worldwide. 
It is a network of networks that consists of millions of private, public, academic, business, and government 
networks. 
 
Q5- What is World Wide Web? 

Ans:- World Wide Web (abbreviated as WWW or W3, commonly known as the Web), is a system of 
           interlinked hypertext documents accessed via the Internet. 
 
Q6- What are the advantages of Networking? 

Ans:- Some of the advantages associated with networking are: 

• Data Sharing: One of the most important uses of networking is to allow the sharing of data. Users can send 
text files, spread sheets, documents, presentations, audio files, video files, etc. to other users. 

• Hardware Sharing: Hardware components such as printers, scanners, etc. can also be shared. For example, 
instead of purchasing 10 printers for each user, one printer can be purchased and shared among multiple 
users thus saving cost. 

• Internet Access Sharing: We can purchase a single Internet connection and share it among other computers 
in a network instead of purchasing multiple Internet connection for each computer. This is very commonly 
found in Internet café (browsing centres), schools, colleges, companies, etc. 

• Usage of network based applications: Such as web browsers, email clients, chat application, audio & video 
calling, etc is another advantage. 

Q7- Which companies provide Internet Connection? 

Ans:- Internet connections are provided by Internet Service Providers such as Bharat Sanchar Nigam Limited 
(BSNL), Airtel, MTS, Vodafone, Tata Docomo, etc. 
 

Q8- What is ISP? Give Some examples. 

Ans:- An Internet service provider (ISP) is an organization which provides you with access to the Internet 
via a dial-up (using modem) or direct (hard wired) or wireless connection.  
Example:-  (BSNL), Airtel, MTS, Vodafone, Tata Docomo, etc. 

https://en.wikipedia.org/wiki/Computer_network
https://en.wikipedia.org/wiki/Metropolitan_area
https://en.wikipedia.org/wiki/Local_area_networks
https://en.wikipedia.org/wiki/City


 

 
Q9- What is Modem? 

Ans:- Á modem is a device that converts digital computer signals into a form (analog signals) that can 
travel over phone lines. 

It also re-converts the analog signals back into digital signals. 

The word modem is derived from its function MOdulator/DEModulator. 
 
Q10- Define the following types of Internet Connectivity? 

Ans:-Some of the commonly used Internet connectivity are: 

Dial-up: Dial-up Internet access is a form of Internet access that uses the facilities of the public 
switched telephone network (PSTN) to establish a connection to an Internet service provider 
(ISP) via telephone lines using a device called MODEM. 

Dial-up connections are extremely slow and in most cases, it is replaced by a high speed connection 
such as DSL or Cable Modem. 
 
DSL: Digital subscriber line(DSL) provide Internet access by transmitting digital data over wires 
of a local telephone network. 
DSL service is delivered along with wired telephone service on the same telephone line. 
 
Cable Internet Access: Cable Internet Access is a form of broadband Internet access that uses 
the cable television infrastructure. 
 

Cable Internet Access is provided through existing cable TV networks; 
 
3G: 3G, short for 3rd Generation is a set of standards used for mobile devices and mobile 
telecommunication services and networks.  
 
High-Speed Downlink Packet Access (HSDPA) is 3G mobile telephony communications protocol that allows 
higher data transfer speeds and capacity. 
 

WiMAX: WiMAX (Worldwide Interoperability for Microwave Access) is a wireless communications 
standard designed to provide mobile broadband connectivity across cities and countries through 
a variety of devices. 
 
WiMAX is a long range system, covering many kilometres and is typically used where DSL or Cable Internet 
Access cannot be used; 
 

WI-Fi: Wi-Fi is a popular technology that allows an electronic device such as computers or mobile 
phones to exchange data wirelessly over a network, including high-speed Internet connections. 
 
Wi-Fi devices such as personal computer, smartphones, video game console, etc. can connect to 
a network resource such as Internet through a device called the Wireless Access Point (WAP). 
 
Wi-Fi is used where cables cannot be run (such as old buildings, outdoor areas) to provide network 
and Internet access. 



 

 
Wi-Fi connectivity is used in home & offices, hotels, college & school campus typically for Internet 
Access. 
 
Q11- Discuss the type of Wired Internet Connectivity? 

Ans:- Dial-up: Dial-up Internet access is a form of Internet access that uses the facilities of the public 
switched telephone network (PSTN) to establish a connection to an Internet service provider 
(ISP) via telephone lines using a device called MODEM. 

Dial-up connections are extremely slow and in most cases, it is replaced by a high speed connection 
such as DSL or Cable Modem. 
 
DSL: Digital subscriber line(DSL) provide Internet access by transmitting digital data over wires 
of a local telephone network. 
DSL service is delivered along with wired telephone service on the same telephone line. 
 
Cable Internet Access: Cable Internet Access is a form of broadband Internet access that uses 
the cable television infrastructure. 
 

Q12- Discuss the type of Wireless Internet Connectivity? 

Ans:- 3G: 3G, short for 3rd Generation is a set of standards used for mobile devices and mobile 
telecommunication services and networks.  
 
High-Speed Downlink Packet Access (HSDPA) is 3G mobile telephony communications protocol that allows 
higher data transfer speeds and capacity. 
 

WiMAX: WiMAX (Worldwide Interoperability for Microwave Access) is a wireless communications 
standard designed to provide mobile broadband connectivity across cities and countries through 
a variety of devices. 
 
WiMAX is a long range system, covering many kilometres and is typically used where DSL or Cable Internet 
Access cannot be used; 
 

WI-Fi: Wi-Fi is a popular technology that allows an electronic device such as computers or mobile 
phones to exchange data wirelessly over a network, including high-speed Internet connections. 
 
Wi-Fi devices such as personal computer, smartphones, video game console, etc. can connect to 
a network resource such as Internet through a device called the Wireless Access Point (WAP). 
 
Wi-Fi is used where cables cannot be run (such as old buildings, outdoor areas) to provide network 
and Internet access. 
 
Wi-Fi connectivity is used in home & offices, hotels, college & school campus typically for Internet 
Access. 
 
Q13- How is the data is transferred on Internet? 

Ans:- 



 

• The data is broken up into bits of same sized pieces called packets. 

• A header is added to each packet explaining where the data has come from, where it should end up and 

where it fits in with the rest of the packets. 

• Each packet is sent from computer to computer until it finds its destination. Each computer on the way 

decides where next to send the packet. All packets may not take the same route. 

• At the destination, the packets are examined. If any packets are missing or damaged, a message is sent 

asking for them to be re-sent. This continues until all packets have been received intact. 

• The packets are now reassembled into their original form. All this done in seconds! 

 

Session 3:- INTRODUCTION TO INSTANT MESSAGING 

Q1- What is IM? 

 OR 

What do you mean by instant messages? 

Ans:- Instant messaging (IM) is a form of communication over the Internet that offers an instantaneous 

transmission of text-based messages from sender to receiver. 

Q2- What are the Key Features of an Instant Messaging? 

Ans:-  

• Text Messages can be sent to one or more person (Similar to SMS) 

• Audio calling and conferencing. 

• Video calling and conferencing. 

• File transfers (Not limited to documents, spread sheets, audio files, video files, etc.) 

• Message history (Save messages for future reference). 

Q3- List any five application based instant messaging software? 

Ans:-  

• Google Talk 

• Yahoo! Messenger 

• Skype 

• Windows Live Messenger 

• Rediff Bol, etc. 

 

Q4- What are Web based instant messaging software? 

Ans:-  

• Meebo 

• Yahoo! Messenger for the Web 

• MSN Web Messenger 

• IMO, etc. 

 



 

Session 4:- CHATTING WITH A CONTACT – GOOGLE TALK 

Q1- What are general rules and etiquettes to be followed while chatting? 

Ans:- 
• Messages should be short and to the point. 

• Always introduce yourself by name if your screen name doesn’t reflect it. 

• Always ask if the other person has time to chat first - regardless of how important you think 

what you have to say is, it’s not going to be well received if the recipient is busy. 

• In a business environment, know exactly what you want to discuss. 

• Typing your messages in uppercase is extremely rude - it’s considered shouting and very 

aggressive. 

• Give people time to respond - Multiple questions sent to a recipient before they’ve had a 

chance to answer can seem more like an interrogation rather than a conversation. 

• It’s important to properly end an IM conversation - you may think the chat is over, but the 

other person may not. While you’re off doing other things, they may be sitting there staring at 

the screen waiting for further communication from you!! 

 
Q2- What are the basic needs to use instant messaging (chat) softwares? 

Ans:-  Instant messaging happens in real-time and the response from participants can be 

           spontaneous. 

           Instant messaging software allows users to view messages received when they are not logged on. 

 

Session 5:- CREATING AND PUBLISHING WEB PAGES - BLOG 
 

Q1- Explain the purpose of a blog? 

  OR 

State the purpose of creating a Blog.  
Ans:-  A blog is a discussion style site used by non-technical (or technical users) users for creating 

          personal web pages.  

         Blog is used to convey messages about events, announcements, news, reviews, etc.  

         Blogs are usually managed using a web browser and this requires active internet connection.  

 

Q2- List any 5 websites that provide blog service? 

Ans:-  
• www.WordPress.com 

• www.blogger.com 

• www.blog.com 

• www.weebly.com 

• www.blogsome.com 

 

Q3- Difference between web page and website ? 

http://www.blogsome.com/


 

Ans:- A Web page is a document for the World Wide Web that is identified by a unique uniform resource 

locator (URL).A website is the group of web pages which are placed in a location on the internet under a 

domain.  

 

Session 6:- USING OFFLINE BLOG EDITORS  

 

Q1- Explain the purpose of an offline blog editor. 

Ans:- If we do not have an active internet connection, we can create blogs using a blog application and 

publish the blog whenever internet connectivity is available. 

 

Q2- List any five offline blog editors. 

Ans:- 
• Qumana 

• Windows Live Writer 

• Blogdesk 

• Blogo 

• Scribefire 

 

Session 7:- ONLINE TRANSACTIONS 

 

Q1- Explain the purpose of Online transactions. 

Ans:-  Online transaction is a payment method in which the transfer of fund or money happens online over 
electronic fund transfer. 
 
 
Q2:- List any five websites that allow online transactions. 

Ans:- 
• IRCTC (www.irctc.co.in), an online portal for booking flight and train tickets. 

• Flipkart(www.flipkart.com), an online shopping portal for buying consumer products. 

• EBay(www.ebay.com), an online portal for buying and selling goods. 

• Redbus(www.redbus.in), an online portal for booking bus tickets. 

• Snapdeal(www.snapdeal.com), an online portal for buying and selling goods. 

 

Q3:- List any three payment tools to use online transactions. 

Ans:-  

 credit card 

 debit card 

 net banking 

 e-gift voucher 

 Cash on Delivery 

 

Q4:- What are the advantages of using Online shopping? 

Ans:-  



 

  A customer does not have sufficient time to visit stores. 

  Visiting a store is more expensive than purchasing a product online. 

  A product or service that is not available in the local market is available online. 

 

Q5:- Explain the following website that provides Online Transaction? 

Ans:- Flipkart:- It is an online store where you can purchase a variety of electronic goods, books, 

accessories,digital cameras, mobile phones and peripherals such as printers, etc. 

Flipkart offers multiple payment methods like credit card, debit card, net banking, e-gift voucher,and Cash on 

Delivery. 

IRCTC:- It stands for Indian Railway Catering and Tourism Corporation. 

    It is an online portal that can be used for booking travel tickets. 

 

 

Session 8:- INTERNET SECURITY 

 

Q1- Explain the purpose of Internet Security. 

Ans:- 

 Internet security is a branch of computer security specifically related to the Internet, often 

involving browser security but also network security. 

 Its objective is to establish rules and measures to use against attacks over the Internet. 

 

Q2:- Explain different kinds of online threats. 

Ans:- Online threats such as Phishing, email spoofing, chat spoofing, etc. 

 

1. Phishing:- It is the fraudulent attempt to obtain sensitive information such as usernames, passwords 

and credit card details by disguising oneself as a trustworthy entity in an electronic communication. 
2. Email spoofing :- It is the creation of email messages with a forged sender address. 

Because the core email protocols do not have any mechanism for authentication, it is common 

for spam and phishing emails to use such spoofing to mislead or even prank the recipient about the 

origin of the message. 

3. chat spoofing:- When a computer system or a user of a computer masquerades to be another 

identity while engaging in chat is known as chat spoofing. 

 

Q3:- What are the guidelines for managing strong passwords. 

Ans:-  
• Keep the length of the password at least 12-14 characters if permitted. 

• Avoid keeping passwords based on repetition, dictionary words, letter or number sequences, 

   usernames, relative or pet names, etc. 

• Including numbers, and symbols in passwords if allowed. 

• Use capital and lower-case letters. 

• Avoid using the same password for multiple sites or purposes. 

• Avoid using something that the public or workmates know you strongly like or dislike. 

https://en.wikipedia.org/wiki/Email
https://en.wikipedia.org/wiki/Message_forgery
https://en.wikipedia.org/wiki/Email_authentication
https://en.wikipedia.org/wiki/Email_spam
https://en.wikipedia.org/wiki/Phishing


 

• Use random password generators if possible. 

Example of a strong password: u1vX:,4Hd{]$ 

 

Q4:- Explain the best practices for Security. 

Ans:-  1.Use strong passwords, a combination of alphanumeric and special characters could be used 

for creating a password that is not so easy to crack or guessed by other users. 

 

2. Backup your data: Always keep copies of personal data in additional media such as compact 

discs, pen drives, etc.  

 

3. Use encryption software: (Usually available within the operating system) to protect your data 

from unauthorized users. If encryption software is not available within the operating system, use 

a 3rd party software. 

 

4. Keeping your username and password private: Never save your username or password on 

computers that are used in shared environments such as internet café. 

 

5. Registering with websites: Read the privacy statement or policy whenever you register with 

a website, the statement or policy will include information about how the website use personal data. 

 

6. Do not share personal information: Websites require you to fill out forms containing fields 

such as name, gender, age, email address, school, etc. Be cautious when filling out such forms; 

research and verify if it’s a trustable website. 

 

7. Use antivirus and antispyware software. 

8. Do not immediately respond to mails from unknown users. 

9. Never install software from unknown sources:  

10. Remove unwanted or unknown software applications 

 

Q5:- What do you mean by secure transactions. 

Ans:- if the website uses secure transaction; usually it is indicated through a digital certificate represented as a 
golden lock in the web browser’s address bar. 
 
Q6:- What do you mean by cookies. 

Ans:- 

 Cookies are programs that are created on your local computer when you visit websites.  

 Though cookies are meant for storing data based on your activity performed during your earlier visit  
such as logon details, details of a shopping cart, visited pages in a website 

 
Q7:- What do you mean by firewall. 

Ans:-  

 Firewalls could be software or hardware and can assist in keeping a compute and a network secure.  

 Firewalls analyze the network traffic and determine if the traffic should be allowed or not. 
 



 

Unit 3:- Word Processing 

Session 2:- MANAGING HEADERS 

Q1:- What do you mean by Header. Write down the steps to insert Headers. 

Ans:- 

 Headers are text or images included at the top of the page.  

 They usually contain important information such as company or department name, logo, page 
numbers, name of the author, etc. 

 Steps:- 

1. Click on the Insert tab on the Ribbon. 

2. Click on the option Header in the Header & Footer group 

3. A drop down list appears which lists predefined header options 

 

Q2:- List any five items that can be added to the header area. 

Ans:- company or department name, logo, page numbers, name of the author, etc. 

 

Session 3:- MANAGING FOOTERS  
 

Q1:- What do you mean by Footers. Write down the steps to insert Footers. 

Ans:- Footers are text or image included at the bottom of the page and may repeat in all pages of the 

document. 

Steps:- 

1. Click on the Insert tab on the Ribbon. 

2. Click on the option Footer in the Header & Footer group. 

3. A drop down list appears which lists collection of predefined Footer options 

 

SESSION 4: MANAGING STYLES 

 

Q1:- What do you mean by Styles or Style sets. 

Ans:- Styles or Style sets are pre-defined or customized options used for creating good looking 

professional documents with least efforts. 

Steps:- 

1. To view list of styles, locate the Style group under Home tab 

2. If we would like to view the list of style sets available, point to Style Set under Change 

Styles option.  

3. A drop-down with different styles will be displayed 



 

 
 

SESSION 5: DOCUMENT TEMPLATE 

 

Q1:- What do you mean by Templates or document templates. 

Ans:-  

 Templates or document templates refer to a sample fill-in-the-blank document that can help in 

saving time. 

 Usually templates are customized documents that may have sample content, themes, etc. 

 

To view sample templates available with word processor 

Go to File > New. You will be displayed with different types of templates 

 
Creation of own template 

 We create the template as a normal document, but the magic step is where we save it. 

Click on File >Save As, and give the template a name. Select Word Template from the Save as type: drop 

down list. 

There is a Templates folder within Microsoft Word. If you save your template there, then 
we’ll be able to see the template in the My templates category. So select that and click Save. 

 

Q2:- Write down the website which provides free templates. 

Ans:-  
• office.microsoft.com/templates 

• www.thepapermillstore.com 

• openoffice.blogs.com/openoffice/templates/ 

• www.docstoc.com 

 

SESSION 6: WORKING WITH PAGE AND SECTION BREAKS 

http://www.docstoc.com/


 

 

Q1:- What is Page Break. Write down the steps to insert page break.  

Ans:- A page break can be inserted anywhere in a document to force the end of a page and the beginning of a    

          new one.      

Steps:- 

a) Click on the Page Layout  tab on the Ribbon. 

b) Click on the option Breaks in the Page Setup group 

c) A dropdown list with options for different types of breaks appears. An explanation is given for 
each type of page or section break. 

 

 
 

Q2:- What is Section Break. Write down the steps to insert Section Break.  

Ans:- A section break controls the formatting of the document content that precedes it, until it reaches  

          another section break.  

Steps:- 

a) Click on the Page Layout  tab on the Ribbon. 

b) Click on the option Breaks in the Page Setup group 

c) A dropdown list with options for different types of breaks appears. An explanation is given for 
each type of page or section break. 

 

Q3:- Differentiate between Page Break and Section Break options of a word document.  

Ans:- A page break can be inserted anywhere in a document to force the end of a page and the beginning of a    

          new one.      

          A section break controls the formatting of the document content that precedes it, until it reaches  

          another section break.  

 

SESSION 7: APPLYING CHARACTER FORMATS 

 

Q1:- What are character formatting features in word processor. 

 
Ans:- There are following character formatting features:- 
 

Font Face: After selecting the text you need to click Font Name in the Font group to select the 



 

particular font style from the fonts listed. 

 

Font Size: After selecting the text you need to click Font Size in the Font group to select the 

particular font size from the values given. 

 

Grow Font: After selecting the text you need to click the icon in the Font group to make the 

font size larger than the current font size by the specified point. 

 

Shrink Font: After selecting the text you need to click the icon in the Font group to make the 

font size smaller than the current font size by the specified point. 

 

Strikethrough: After selecting the text you need to click the icon in the Font group to make a 

strike through the middle of the selected text. 

 

Subscript: After selecting the text you need to click the icon in the Font group to make the 

selected text lower than the normal text position. 

 

Superscript: After selecting the text you need to click the icon in the Font group to make the 

selected text higher than the normal text position. 

 

Clear Formatting: Clear Formatting is used to clear the character formatting (such as Bold, 

Italics ,Underline, font face & size, superscript & subscript etc.) of the selected text. To remove the 

character formatting, select the text and click on icon in the Font group. 

 

Text Highlight Colour: Use this option to change the background colour. To do so, select the 

text and click on icon in the Font group. You can choose the background colour by clicking 

on the down arrow on the icon. 

 

Font Colour: Use this option to change the colour of the text. To do so, select the text and click 

on icon in the Font group. You can choose the text colour by clicking on the down arrow on 

the icon. 

 

Change Case: Word processor helps us to change the text case to capital letters or small letters. 

You can also capitalize each word in the sentence and capitalize the starting word of the sentence 

using Change Case under Font Group. To do so, after selecting the text you need to click the 

icon in the Font group 

 

Sentence Case: On selecting this option from the dropdown list, the first character in the first 

word of the selected sentence will be converted to Capital Letter (Uppercase). 

 

Lowercase: On selecting this option from the dropdown list, the selected text will be converted to 

Small Letters (lowercase). 

 



 

UPPERCASE: On selecting this option from the dropdown list, the selected text will be converted 

to Capital Letters (UPPERCASE). 

 

Capitalize Each Word: On selecting this option from the dropdown list, the first character in all 

the words of the selected sentence will be converted to Capital Letter (Uppercase). 

 

tOGGLE cASE: On selecting this option from the dropdown list, the small letters in the 

selected text will be converted into capital letters and capital letters will be converted into 

small letters.  

 

Q2:- What do you mean by Change case or cases option in Word Processor. Define the types of cases 

available. 

 

Ans:- Change Case: Word processor helps us to change the text case to capital letters or small letters. 

You can also capitalize each word in the sentence and capitalize the starting word of the sentence 

using Change Case under Font Group. To do so, after selecting the text you need to click the 

icon in the Font group 

 

Sentence Case: On selecting this option from the dropdown list, the first character in the first 

word of the selected sentence will be converted to Capital Letter (Uppercase). 

 

Lowercase: On selecting this option from the dropdown list, the selected text will be converted to 

Small Letters (lowercase). 

 

UPPERCASE: On selecting this option from the dropdown list, the selected text will be converted 

to Capital Letters (UPPERCASE). 

 

Capitalize Each Word: On selecting this option from the dropdown list, the first character in all 

the words of the selected sentence will be converted to Capital Letter (Uppercase). 

 

tOGGLE cASE: On selecting this option from the dropdown list, the small letters in the 

selected text will be converted into capital letters and capital letters will be converted into 

small letters.  

 

Q3:- Define the followings. 

a. Grow Font 

b. Shrink Font 

c. Strikethrough 

d. Subscript 

e. Superscript 

f. Clear Formatting 

 

SESSION 8: INSERT GRAPHICAL OBJECTS AND ILLUSTRATIONS 

 



 

Q1:- What do you mean by objects in word processor. 

 
Ans:-  

 Objects can be almost any form that can be generated as a computer file. 

 Sounds, Music, drawings, documents spreadsheets, etc. are all examples of possible objects that we 

can include in a document, or link to a document. 

 

Q2:- What is the difference between Embedding and Linking an object. 

 

Ans:-  Embedding an object makes it part of the document while linking an object does not include the object 

file into the document files. 

 

Q3:- What is Clip Art. Write down the steps to insert clip art. 
 
Ans:-  

 Clip arts are pre-defined images available for use in documents. 

 Clip Art can help in making a document look colourful and presentable. 

 For example, if we would like to create a greeting card for your friend, you can use clip arts such as 
balloon, flowers, etc. along with text message. 

 

Steps:- 

1. Click on the Insert tab on the Ribbon. 

2. Click on the option Clip Art in the Illustrations group 

3. The Clip Art Task Pane appears. Enter the clipart category name in the search box and Click         

     Go. For example, if we want to insert a logo, type logo in the search box and Click “Go”. 

4. Once you click Go , a window appears along with list of clip arts matching the search keyword . 

 
 

Q4:- Write down the website which provides free clip arts. 

Ans:-  

• www.openclipart.org 

• www.pdclipart.org 

• www.clker.com 

• www.freeclipartnow.com 

• www.wpclipart.com 

 

SESSION 9: TEXT WRAPPING 

 

http://www.wpclipart.com/


 

Q1:- What is Text Wrapping. 
 

Ans:- Text wrap is a feature supported by many word processors that enables you to surround a picture or 

diagram with text. The text wraps around the graphic.  

 

Steps:- 

             Wrap Text option is available under Text section of the Insert Tab.  

In Word: 

select the Text Wrapping dropdown arrow in the Arrange group under the Format tab. 

  
Q2:- List any five word wrapping options available in a word processing software. 
Ans:-   

1. Square 

2.  Tight 

3. Through 

4. Top and Bottom 

5. Behind Text 

6. In Line with Text 

7. In Front of Text 

  

SESSION 10: INSERTING OBJECTS 

 

Q1:- What down the steps to insert the object. 
Ans:-  
 

Steps:- 

• Select Insert Tab 

• Click Object under Text section. A dialog box will be displayed 

 
 



 

•Select Create from File Tab 

• Click Browse and select a file such as a spread sheet or a PDF document that is available 

  on your computer, Click Open and Click OK 

• the document is available embedded within your word document. 

 

Q2:- What are the properties of Embedded Object. 
Ans:-  

1. The embedded objects cannot be printed. 

2. The person opening our document must have the relevant software loaded on their computer 

    to operate the embedded file. 

3. If we embed an object, the size of our document increases significantly and this may cause 

    problems in emailing the document as an attachment. 

4. If we link an object, the person opening that document must have a direct connection to the 

   original file location of the object. 

 

SESSION 11: INSERT SHAPES, SYMBOLS AND SPECIAL CHARACTERS 

 

Q1:- What down the steps to insert the shapes. 

Ans:- 

1. Click on the Insert tab on the Ribbon. 

2. Click on the option Shapes in the Illustrations group 

 

3. Once you click the Shapes option a dropdown list with pre-defined shape such as box, circle, 
etc. appears. 
4. You can select the shape from the list of shapes available and draw the shape by dragging 
the mouse with the left button clicked. For example, if would like to insert a square, select the 
box shaped item from the list, click and drag the shape to draw a square 

 
Q2:- What down the steps to insert the symbols. 
 

Ans:-   
1. Click on the Insert tab on the Ribbon. 

2. Click on the option Symbol in the Symbols group 

 



 

 
3. A dropdown list appears 
 

 
 

4. Select a symbol from the list and double-click on to insert the symbol into the document. 
 

Unit 4: Spreadsheet  

SESSION 1: USE AUTOSUM IN CELLS 
 
Q1:- What is Autosum feature? 
Ans:- Autosum is used for adding the values given in cells automatically without writing the formula to perform the 
operation. 
 

Steps:- 
Click on the AutoSum option available under Editing Group in the Home tab. 

 

SESSION 2: CONDITIONAL FORMATTING 
 

Q1:- What is Conditional formatting? 
Ans:- Conditional formatting allows you to change the formatting (font color, border, shading) of the cells 
based on the values in it.One or more cells can be selected, and create rules (conditions) for when and how 
those cells are formatted. The conditions can be, based on the selected cell's contents, or based on the 
contents of another cell.  
 

For example  

        Highlight the marks of the students who got marks greater than 80 with green colored text  

 

Steps:- 
 

Click on Conditional Formatting option available under Styles group in the Home tab. A drop down list appears. 



 

      
 

Q2:- List any five conditions/formats/items that can be used for conditional formatting. 
  OR 
 Which formats can be controlled by Conditional formatting? 
 
Ans:- We can control the following formats: 
• Number format 
 • Font, font style, and font colour (but not font size) 
 • Fill colour and fill pattern 
 • Border colour and border style (but not border thickness) 

 

SESSION 3: HIDE / UNHIDE / FREEZE ROWS AND COLUMNS 
 

Q1:- What is Hiding rows and columns? 
Ans:- Hiding feature of a spreadsheet is the ability to hide a row/column that is not to be shown to the end 
user. The data in hidden row/column is available for calculations though not visible! 
 

Steps:- 
 

• In order to hide any row or column you can either select the particular row or column that is to hidden or 
just one cell in the corresponding row or column. 

 

• Click on Format option available under Cells group in the Home tab. 

 
 
• A dropdown list appears as shown below. 



 

        
• Click on Hide & Unhide > Hide Rows. 
 
Q2:- What is UnHiding rows and columns? 
Ans:- UnHiding feature of a spreadsheet is the ability to unhide a row/column that is to be shown to the end 
user. 
 

Steps:- 

• In order to unhide the row or column that is hidden you have to select any cells before and 
after the cell that is hidden then click Unhide Rows in the Format option available under Home tab. 
 
Q3:- What is Freezing rows and columns? 
Ans:- When we are dealing with a huge amount of data that spans several rows or columns, you may want the 
headers to remain constant (frozen) while you scroll through the data so that you can see the identifying 
names of the rows/columns. 
 

Steps:- 

• In order to freeze rows or columns click on Freeze Panes option available under Window 

group in View tab. 

• A drop down list appears as shown below. Click on Freeze Panes. Doing so will freeze all 
the rows above and all the columns to the left of the selected cell. Scroll your mouse in the 
spreadsheet the frozen rows and columns remain constant. 
 

    
 

SESSION 4: SET PAGE BREAKS 

Q1:- What is Page Breaks in Spreadsheet? 
Ans:-  

 To print a worksheet with the exact number of pages that you want, we can adjust the page 
breaks in the worksheet before printing it.  



 

 This feature is very useful especially when printing huge sheets.  

 We can use the Page Break view to see how other changes (e.g. changing row height /column width) 
affect the automatic page breaks. 
 
On the View tab, in the Workbook Views group, click Page Break Preview. 

 
Q2:- How can we insert vertical and horizontal Page Breaks in Spreadsheet? 
Ans:- 

 To insert a vertical page break, select the column to the right of where you want to insert 
the page break. 

 To insert a horizontal page break, select the row below where you want to insert the page break. 

 
        Click on Breaks down arrow under Page Setup group in the Page Layout tab. A dropdown 
             appears as shown below. 

 

  
• Click on Insert Page Break option. 
 

Note: We can also remove the page breaks by clicking the Remove Page Break option in Breaks 

drop down list. 
 

SESSION 5: SET PAGE LAYOUT 

        Q1:- What is Page Layout in Spreadsheet? 

Ans:- If we have a worksheet that contains a huge amount of data with many charts and we want a 
professional looking printout. Spread sheet software provides various page layout options for organizing pages 
using the Page Layout option. 
 
We can set the following features in Page Layout Option  
  • Margins 
  • Orientation 
  • Page headers and footers 
  • Hide or display grid lines 
  • Size of the page 
  • Define the print area 
  • Specify the background 

Q2:- How can we set the Margins in Spreadsheet? 

Ans:- 

• Click on Margins option under Page Setup group, a dropdown list appears 



 

     

We can either select anyone of the predefined margin option available or else we can define 
our own margin settings by clicking Custom Margins. option. A dialog box appears. 

     

 

Q3:- How can we set the orientation in Spreadsheet? 

Ans:-We can set the orientation of the page to either Portrait or Landscape by clicking the Orientation option 

under Page Setup group in the Page Layout tab. 

Q4:- How can we set size of page in Spreadsheet? 

Ans:-We can set the size of the page by clicking the Size option under Page Setup group in the Page Layout 

tab. 

Q5:- How can we set the PrintArea in Spreadsheet? 

Ans:- We can specify the area to be printed by selecting the area and then clicking Print Area 
option under Page Setup group in the Page Layout tab. A drop down list appears as shown 
below. 

     

 

SESSION 6: MANAGE WORKBOOK VIEWS 

Q1:- Elaborate the five types of Views available in a spreadsheet.  

Ans:- 



 

1.  Normal View: The default view of the spreadsheet application is the Normal. It’s a collection of 

 cells arranged in the work area. 

2. Page Layout: You can select the Page Layout view in order to quickly fine tune a worksheet that 

 contains many charts or huge amounts of data and achieve professional looking results. 

3. Page Break Preview: This option is similar to the Page Layout option except you can set the area 

 that is to be set as a page after inserting page break. 

4. Custom Views: If you would like to view selected areas of a document , you can use the custom 

 view option. For example, if you would like to point out certain row and column, you can add that 

 to the Custom view. 

5. Full Screen: Selecting this option makes the workbook cover the entire screen. All tabs are 

 hidden from view. To get back the tabs, click on File> Restore. 

SESSION 7: APPLY CELL AND RANGE NAMES 

Q1:- What is Range Name. How can we give Range Name in Spreadsheet. 

Ans:- We can assign names to cells in a worksheet and use it for quickly locating specific cells by 
entering the names. 

• Select the values (Keep the Ctrl key pressed and click on the cells – you will be able to select 
selective cells together!). Right click and select Name a Range…. Alternatively, you can 
select Define Name under Defines Names group in the Formulas tab. 
 
• A New Name dialog box appears prompting to enter a name. Enter Range Name in the Name field 
and click OK (figure below).  

  

 

SESSION 8: CREATE MODIFY AND FORMAT CHARTS 

Q1:- What is Chart. Write down the steps to create chart. 

Ans:- A chart is a graphical representation of data, in which the data is represented by symbols, such 
as bars in a bar chart, lines in a line chart, or slices in a pie chart. A chart can represent tabular numeric data, 
functions or some kinds of qualitative structures. 
 
Steps- 
 



 

 • Select all the data. 
 • Click on the chart type that you want from Charts group under the Insert tab. 
 

Q2:- What down the elements of Chart. 

Ans:-  

 1. Chart Area of the Chart 
 2. Plot Area of the Chart 
 3. Data Points that are plotted in the chart 
 4. Horizontal and Vertical Axis in the chart 
 5. Legend of the chart 
 6. Chart and Axis Title used in the chart 
 7. Data Label for identifying details of data point in the chart 

Q3:- Discuss the types of Charts. 

Ans:-  

1. Bar charts: A bar chart (horizontal bars) emphasizes the comparison between items at a fixed 

 period of time. This chart type also includes cylinder, cone, and pyramid subtypes. 

2. Column charts: A column chart, unlike a bar chart to which it is often compared, emphasizes 

 variation over a period of time. This chart type also includes cylinder, cone, and pyramid subtypes 

3. Line charts: A line chart shows the relationship of the changes in the data over a period of time. 

4. Pie charts: Pie charts contain just one chart data series. A pie chart shows the relationship of the parts 

to the whole. 

5. Area charts: An area chart shows the relative importance of values over time. 

6. XY (Scatter) charts: Scatter charts are useful for showing a correlation among the data points that may 

not be easy to see from data alone. 

 

SESSION 9: SORT AND FILTER DATA 

Q1:- What is Sorting. Write down the steps to sort the data. 

Ans:- Sorting is a feature that helps us to arrange the selected data either in an ascending or descending 
order. 

Steps:- 

• Select the data to be sorted and then click on Sort option under Sort & Filter group in the Data tab. A dialog 
box appears as shown below. 

   

Q2:- What is Filtering. Write down the steps to filter the data. 



 

Ans:- Filter is a feature used for extracting particular data using some conditions. 

Steps:-  

• Click the Filter option available under Sort & Filter group in the Data tab. Before applying a 
filter you have to select the data along with the header 

   

• Once you click on filter, the headers will be displayed with a down arrow as shown below. 

   

Unit 5: Digital Presentation  

SESSION 1: INSERTING A MOVIE CLIP 

Q1:- Write down the two ways to insert Movie clip in Presentation. 

Ans:-  We can insert a movie in two ways: 

  • Using Insert tab 
  • Using Title and Content Layout Option 

1. Using Insert Tab 

Click on Movie option under Media clips group in the Insert tab, a drop down appears as shown 
below. 

    

 

We can select the Movie from File… option to insert the movie clip 

2. Using Layout Option 

 Click on Layout option available under Slides group in the Home tab, a dropdown list appears 
as shown below. 



 

  
Click on Title and Content option 

SESSION 2: INSERTING AN AUDIO CLIP 

Q1:- Write down the steps to insert Audio in Presentation. 

Ans:- Click on Sound option under Media clips group in the Insert tab, a drop down appears 

 

  
 

 We can select the Sound from File… option to insert the sound clip. 

 We can locate the audio clip and click OK to insert the same in the slide. 
 

SESSION 3: WORKING WITH TABLES 

Q1:- State the purpose of creating Tables in a digital Presentation. Mention two ways to insert a table in a 

presentation.  

Ans:- Table is used to represent the statistical data meaningfully Tables .It can be used to present text and 
numerical data. Data is shown in the grid format.  
Tables can be inserted in two ways  

 Using Insert tab  

 Using Title and Content Option  
 

Q2:- Write down the steps to insert table in the presentation. 

Ans:- Click on Table option under Tables group in the Insert tab, a drop down appears as shown 

below. 



 

     

 
 
 

Q3:- Write down the steps to insert table using the Title and Content Layout in the presentation. 

Ans:-  

 Click on Layout option available under Slides group in the Home tab. 

 Click on Title and Content option from the dropdown list 

 You can insert the table in the slide by clicking the  icon available within the layout. Once you click 
the icon, a dialog appears as shown below. 

  

Q4:- How can the table design be changed in presentation. 

Ans:-  

 We can change the design of the table by changing background, borders or effects by using Table 
Styles group in the Design tab.  

 To use a particular design, Select a design under Table Styles group and double-click on it. 
 

SESSION 4: WORKING WITH CHARTS 

Q1:- State the purpose of creating Charts in a digital Presentation. Mention two ways to insert charts in a 
presentation.  
Ans:- Presentation software enables the user to insert charts in slides to present statistical table data in 
a pictorial representation. This ensures that the audience can grasp complex data at a glance. 

Charts can be inserted in two ways  

 Using Insert tab  

 Using Title and Content Option  



 

 

Q2:- How can the chart style be changed in presentation. 
Ans:-  

 We can change the colors and effects of the chart by using Chart Styles available under Design 
tab. 

 To change to a different style, select a style from Chart Styles and double-click on it.  
 
Q3:- What are the basic guidelines about the charts in presentation. 
Ans:-  

• Convey one message per chart. Make the message the heading. 
• Make the chart easy to read. Label the X and Y axis and label the lines, bars, or pie wedges. 
   Make the most important text largest, the most important data lines or sections darkest. 
• Make bars and columns wider than the spaces between them. 
• Be accurate. Always start a numerical axis at zero. Compare only like variables. 
• Eliminate all unnecessary details. Avoid grid lines, data points, boxes, etc. unless they relate 
   to the message. 
• Use a few (maximum four) colors per visual. 

 

SESSION 5: INSERTING TRANSITIONS 

Q1:- What is Transition. Write down the step to insert transition. 
Ans:- A slide transition is the visual motion when one slide changes to the next during a presentation.  
 

 spetS:-

click the Animations tab.  

      To apply, select an effect from Transitions to this slide group and double-click on it. 

 

Q2:- Mention two points stating the effective use of transition in a presentation.  
Ans:- 

 Transition effects can help in increasing audience’s interest during a present 

 It brings the special effects in the slide. 
 

SESSION 6: INSERTING ANIMATIONS 

 
Q1:- What is Animation. Write down the steps to insert animation. 
Ans:- Animation allows us to put slide elements, such as text and graphics, in motion within a slide. 
 
Steps:- 

 Click Animations tab 

 To apply, select the graphical object and click Animate under Animations group. Select the animation 
effect under the Animate dropdown list. 



 

 

  
 
Q2:- Mention two points stating the effective use of animation in a presentation.  
Ans:- 

 It helps focus audience attention on information.  

 It controls the flow of information especially while explaining a diagram.  

 It reveals concepts one by one.  

 

SESSION 7: GROUPING OBJECTS 
 
Q1:- What is Grouping. Write down the steps to group the objects. 
Ans:- Grouping can help when you want to move, rotate or resize multiple objects in a presentation. We can 
group objects such as pictures, clip art, shapes and text box; once grouped they appear as a single object. 

Steps:- 
 
To select more than one objects in the slide hold down the ctrl key and select the object in 
the slide. 
To group the objects, click Format tab. 
 

 
 

We can select the Group option available under Arrange group in the Format tab. 
 
 

 
 
Similarly you can ungroup the grouped objects by selecting the ungroup option available under 
Group dropdown menu. 
 

SESSION 8: INSERTING SPEAKER NOTES 
 
Q1:- What are Speaker Notes. Write down the steps to insert Speaker Notes. 
Ans:- 

 Speaker notes are guided text used by the presenter during a presentation.  



 

 Speaker notes can be short or long texts that can be used as a reference by the presenter while making 
a presentation. 

 

Steps:- 
 
First way 

To add notes to a particular slide, select the slide and type the notes in the Click to add notes 
area located at the bottom of the presentation software 

 

 SPEAKER 
Second way 

Alternatively, you can select View tab and click Notes page under Presentation Views Group.TES 
 
 
Q2:- What are key things of Speaker Notes. 
Ans:-  

1. They should not restate the contents of the slide. 
2. Speaker notes should support the content of the slide with in-depth information. 

 
SESSION 9: REVIEWING CONTENT 
 
Q1:- Write the points to be kept in mind to make an effective presentation for the audience. 
Ans:-  

1. Do prior research, know the topic and collect the material of what you will talk about.  
2. Highlight key points that are necessary for the audience to remember. Keep the points as short as       
    possible. 
3. Avoid too much text Summarize the content as bullet points. Use simple language and limit the       
    number of bullets to three or four per slide. 
4. Limit the number of slides - On average, one slide per minute is recommended.  
5. Fancy fonts must be avoided.  
6. Keep slide color scheme consistent throughout the presentation.  
7. Transitions and Animations must be used carefully to avoid distractions.  
8. Use a slide design template to keep presentation look consistent.   

 
SESSION 10: PREPARING TO DELIVER A PRESENTATION 
 
Q1:- Rajat works for an event management company. She has prepared a presentation and while setting up 
the Slide Show she is getting the following options, explain them briefly.  

(i) Presented by a speaker  



 

(ii) Browsed by an individual  
(iii) Browsed at a Kiosk  

 

Ans:  
(i) Presented by a speaker (full screen) option can be used if the presentation is to be made to an 
audience .  
(ii) Browsed by an individual is used when the presentation is to be made to an individual  
(iii) Browsed at a Kiosk is used when the presentation is to be given at Kiosk computer terminal.  

 
Q2:- What is Kiosk. 
Ans:- A kiosk is a computer terminal featuring specialized hardware and software designed within a public 
exhibit that provides access to information and applications for communication, commerce, entertainment, 
and education. 

 
SESSION 11: PRINT A PRESENTATION 
 
Q1:- What option do we have in “print what” option while printing the presentation. 
Ans:-  
 

1. Slides   2. Handouts   3. Notes Page  4. Outline View  

 
 
Q2:- Define Handouts and Outline. 
Ans:-  Handout are print out of the presentation that is given to the audience as a reference material. 
          Outline prints only the text part of the presentation, without slides. 

 

Unit 6: Email Messaging 

SESSION 1: WORKING WITH CALENDAR 
 
Q1:- What is Time Management. 
Ans:- Time Management is the act of planning to stay organized that will result in increased efficiency 
and productivity. 
 

Q2:- What is a Calendar Software? State its purpose.  
Ans:- Calendar software provides the user an electronic version of a calendar. It is a time management tool. 
 
Purpose:-  



 

It is a system of organizing days for social, religious, commercial, or administrative purposes. It can be used to 
create appointments and schedule day-to-day activities.  
For Example Outlook Calendar  
 

Q3:- Explain three views supported by Calendar Software.  
Ans:-  

1. Day View can be used to schedule an activity for a particular time in the day  
2. Week View can be used to view the appropriate days in the week.  
3. Month view shows calendar for a month. Monthly schedule can be planned. Any 
appointments/meetings/commitments previously set in the day/week view will also be reflected here.  
 

 
 

Q4:- How can the Calendar setting be changed in Microsoft Outlook. 
Ans:-    

 We can set the options for the calendar by selecting Tools > Options.  

 Click on Calendar Options. 
 

 
SESSION 2: SCHEDULE AN APPOINTMENT 
 
Q1:- What are the two ways by which we can schedule Appointment. 
Ans:-  We can schedule an appointment in two ways: 

1. Using menu bar. 
2. Using calendar view. 

 
Steps:-  

Go to File > New > Appointment 
 

Q2:- What is Recurring Appointments. 
Ans:- Recurring appointments can be used for scheduling repetitive tasks. 

SESSION  
Steps:-  

Right-click on the calendar and click New Recurring Appointment. 
 
 

 
SESSION 3: CATEGORIZE AN APPOINTMENT 

 



 

Q1:- How can we categorize the appointments. 
   Or 
        What is use of categorizing the appointment? 
 

Ans:- We can categorize appointments in time management software by giving specific colors to 
appointments. 
For example, we can use green color for all school related activities and blue for all personal activities. 

 
Some categories are shown XE 

RCISE  
 
SESSION 4: SHARE A CALENDAR 
 
Q1:- What are the two ways by which the calendar is shared. 
Ans:- Two ways are: 
 

1. Publish My Calendar  
2. Send a Calendar via E-mail  

 
Q2:- What is the use of sharing calendar. 
Ans:-  

 Sharing your calendar helps to share various segments of your time-centric life with your spouse, 
family, and others. 

 Calendar sharing is the last frontier for true collaboration and social networking. 

  

SESSION 5: PRINT A CALENDAR 
 
Q1:- Which options are available under “print style” while printing the calendar. 
Ans:-  

1. Daily style 
2. Weekly style 
3. Monthly style 

 
Q2:- How can we print the private appointments. 
Ans:- We can print the private appointments by uncheck the Hide details of private appointments check box. 

 
SESSION 6: CREATING A MEETING REQUEST 
 
Q1:- What is a Meeting. Write down the steps to create meeting. 
Ans:- A meeting is an appointment to which you invite people or reserve resources for (meeting hall, 
equipment etc.). 
Steps:-  

 Go to File > New > Meeting Request 



 

 
 

SESSION 7: RESPOND TO A MEETING REQUEST 
 
Q1:- Write down the responses of Meeting Request. 
Ans:- 

1.  Accept 
2.  Tentative 
3.  Decline  
4. Propose New Time  

 

 
 

SESSION 8: CREATE AND EDIT A TASK 
 
 
 
Q1:- What is a Task. Write down the steps to create task. 
Ans:- Tasks refers to actions that can be performed by an user; tasks may include action items such as booking 
a conference room, booking tickets, reminder for a task completion itself, etc. 
 
Steps:-  

 
 Go to File > New > Task 

 
 
SESSION 9: CREATE AND EDIT A NOTE 

 
Q1:- What is a Note. Write down the steps to create note. 



 

Ans:- Notes are short text messages that can be used for taking quick notes. 
 
Steps:- 

Go to File > New > Note 
 

 
To view the notes that we have created, click Notes in the calendar application 

 
 
SESSION 10: CREATE AND EDIT A JOURNAL ENTRY 
 
Q1:- Define Journal Entry. 
Ans:- A Journal entry creates a timeline of transactions that can be linked to a contact. A transaction might be 
an email, task, appointment etc. 
 

Q2:- List the activities recorded under Journal entry.  
Ans:- The following activities can be automatically recorded under Journal entry:  

 Emails Sent & Received  

 Telephone calls  

 Meeting requests & responses  

 Office documents you manage  
 
 

  
 

Q3:- Write down the steps to see Journal Entries. 
Ans:-  

 Go to Tools >Options 

 Click on Journal Options button. 
 



 

Unit 7: Database Development 

 
SESSION 1: DATABASE CONCEPTS 

 
Q1:- What is Database. 
Ans:- A database is an organized collection of data. 

 
Q2:- What is DBMS. Give some examples of dbms software. 

Ans:- A database management system is a software package with computer programs that controls the 
creation, maintenance, and use of a database. 

For example Oracle, IBM DB2, Microsoft SQL Server, Microsoft Access, PostgreSQL, MySQL, FoxPro, and 
SQLite. 

 
Q3:- Differentiate between Flat File and Relational Database.  
   Or 
         How many type data is organized. 
Ans:- Flat File: Data is stored in a single table. Usually suitable for less amount of data.  

Relational Database: Data is stored in multiple tables and the tables are linked using a common field. 
Relational is suitable for medium to large amount of data.   
 

Q4:- What is Database Server. 
Ans:- 

 Database servers are dedicated computers that hold the actual databases and run only the DBMS and 
related software.  

 Typically databases available on the database servers are accessed through command line or graphic 
user interface tools referred to as Frontends; database servers are referred to as Back-ends. Such type 
of data access is referred to as a client-server model. 

 
Q5:- What is RDBMS. 
Ans:- 

 A relational database management system (RDBMS) is a database management system that is 
based on the relational model as introduced by E. F. Codd. 

 In the relational model of a database, all data is represented in terms of tuples, grouped into relations. 
 

SESSION 2: DATA STORAGE 
 
Q1:- Define the following terms 

a. Table 
b. Columns or Fields 
c. Rows or Records 

 
Ans:-   a) Table: A table is a collection of related data held in a table format within a database. It consists of     
                           columns, and rows. 

b) Column or Field is a set of data values of a particular simple type, one for each row of the table. 
  c) Row also called a record or tuple represents a single, data item in a table. 
 



 

Q2:- What are Data Types. Write down the different data types. 
Ans:- Datatypes are used to identify which type of data (value) we are going to store in the database. 
 
         There are following data types available 

• Numeric Types 
• Alphanumeric Types 
• Binary Types 
• Date time 
• Other Variable types 
 

Q3:- List the data types used in a DBMS /RDBMS? 
Ans:-There are following data types used in a DBMS/RDBMS 

• Numeric Types 
• Alphanumeric Types 
• Binary Types 
• Date time 
• Other Variable types 
 

Q4:- State the relationship and difference between a primary and foreign key? 
    Or 
         Define Primary key and foreign key 
Ans:-  

Primary Key A primary key is a unique value that identifies a row in a table. For example, Student Table 
contains columns such as Admno, Name, DOB , Address, Phone and Admno can be considered as Primary Key  
 
Foreign Key: a foreign key is a field or a column that is used to establish a link between two tables. In simple 
words you can say that, a foreign key in one table used to point primary key in another table.  
 
 

Q5:- List datatypes available in Numeric Datatype? 
 Ans: 
  Numeric Types: 

 

 
Q6:- List datatypes available in Alphaumeric Datatype. 
Ans:-  



 

 
 
Q7:- List datatypes available in Date Datatype? 
Ans:- 
  Date time: 

   
 

Q8:- Why do we use Binary datatypes. Explain? 
Ans:- Binary data types are used for storing data in binary formats. Binary data types in a database can 
be using for storing photos, music files, etc. 
Binary Types: 

  
 

SESSION 3: MANIPULATING DATA 
 
Q1:- What is DDL and DML? Give one example of each.  
Ans:- 

 Data Definition Language (DDL) A data definition language or data description language (DDL) is a standard 
for commands that define the different structures in a database. DDL statements create, modify, and remove 
database objects such as tables, indexes, and users.  
Example CREATE, ALTER, and DROP.  
 
Data Manipulation Language (DML)  
A data manipulation language (DML) is a language that enables users to access and manipulate data in a 
database. The goal is to provide efficient human interaction with the system. 
For Example Insert, Update, Delete and Select   
 
Q2:- Define the types of DML. 
Ans:- There are two types of DML: 

• Procedural: The user specifies what data is needed and how to get it 
• Nonprocedural: The user only specifies what data is needed. This is easier for the user but 



 

may not generate code as efficient as that produced by procedural languages.  
 

 
SESSION 4: CREATING A DATABASE OBJECT 
 
Q1:- What is the file extension for databases created using OpenOffice.Org Base? 
Ans:-  .odb 
 

Q2:- List any three file formats that can be managed using OpenOffice.Org Base? 

Ans:-  .odt, .ods, .odp 
 

SESSION 5: CREATING A TABLE 
 
Q1:- Write down the steps to create Table in DBMS. 
Ans:-  

After creating the database, we see a window as shown below. 

 
Click on Create Table in Design View… option available under Tasks and a Table Design window appears as 
shown below. 

 

    
Specify the field name and data type of the field to be created by selecting the appropriate type available 
under Field type dropdown list. 

 



 

SESSION 6: BUILDING FORMS 
 
Q1:- What is Form in DBMS. 
Ans:- A form provides the user a systematic way of storing information into the database. It is an interface 
in a user specified layout that lets users to view, enter, and change data directly in database 
objects such as tables. 

 
 
SESSION 7: CREATE AND MANAGE QUERIES 
 
Q1:- Write down the SQL Queries for the following table- EMPLOYEE 
  

FIELD TYPE KEY 

ID Integer PRIMARY KEY 

NAME Varchar(20)  

AGE Integer  

ADDRESS Varchar(25)  

a) Write the SQL command to create above table.  
b) Write the SQL command for inserting the following values in the given table. 

ID NAME AGE ADDRESS 

1 ABHIRAM 22 ALLAHABAD 

2 ALKA 20 GHAZIABAD 

3 DISHA 21 VARANASI 

4 ESHA 21 DELHI 

5 MANMEET 23 JALANDHAR 

 

c) Modify the AGE by increasing from 20 to 25 for ID 2.  
d) Delete the record of ID 4.  
e) Display all the records in descending order of AGE. 

 
Ans:-         a) Create table Employee 
  (   Id integer primary key, 
      Name varchar(20), 
                               Age integer, 
                               Address Varchar(25) 
  ); 
  

       b)    Insert into Employee values (1,”Abhiram”,22,”Allahabad”); 
   Insert into Employee values (2,”Alka”,20,”Ghaziabad”); 



 

   Insert into Employee values (3,”Disha”,21,”Varanasi”); 
   Insert into Employee values (4,”Esha”,21,”Delhi”); 
   Insert into Employee values (5,”Manmeet”,23,”Jalandhar”); 
 

                     c)    Update Employee set age=25 where ID=2; 
 
                    d)     Delete from Employee where ID=4; 
 
        e)     Select * from Employee order by age desc; 

 
SESSION 8: DESIGN REPORTS 
 
Q1:- What is Report in DBMS. 
Ans:- A report is used to generate the overall work outcome in a clear format. 


